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Android troubleshooting

Android | Troubleshooting | Support

A
Written by Andy Neil
Updated over a year ago

Introduction

This article will guide you through troubleshooting Android digital signage devices. Typically, these devices are mounted behind the TV or display, connected via HDMI, and networked using an ethernet cable. While Wi-Fi is an option, a direct ethernet connection is recommended. The device is powered using a standard micro USB cable and a 5V 2A USB adapter.

Instruction

Issue

Potential Cause

  • Screen is black

  • Digital signage device is not plugged into the display.

  • Display is on the wrong input or turned off.

  • Digital signage device is not powered on.

  • Content is not playing properly.

  • Screen shows a white background with blue letters (activation code)

  • Device is offline.

  • Device is not communicating with the CMS platform.

  • Device is not activated.

  • Screen displays a checkmark

  • No content published to the player.

  • Device is offline.

  • Screen shows a bouncing logo

  • Device is turning on.

  • Device is frozen.

  • Screen is on a menu or incorrect content

  • Display is on the incorrect input.

  • Device is not set up properly.

Basic Troubleshooting:

  1. Is the display powered on?

    1. Use the remote to power on the display.

    2. Press the menu button on the remote; the on-screen menu should appear.

      1. If it does not, the display may be off or faulty.

      2. Verify the display has power by looking for flashing lights or other indicators.

      3. Try a different power outlet if possible.

  2. Is the device plugged in? (Power, Network, and Display)

    1. Check for lights on the device.

      1. Identify which lights are on (Power, Network).

    2. If no lights are present, try a different power outlet or power adapter.

  3. Is the display on the correct input?

    1. Use the remote to check and cycle through all available inputs.

    2. Wait a few seconds for each input to see if the correct one appears.

  4. If you unplug the power from the device and plug it back in, is there any sign of life on the display?

    1. Ensure the display is on the correct input.

  5. If possible, connect a keyboard and mouse to the digital signage device.

    1. Hold down the "ALT" key and press "TAB."

      If a menu appears at the bottom, the device is functioning.

    2. While holding "ALT" + "TAB", use the mouse to click the "Home" symbol on the device.

    3. Click "Cancel Autoplay" or "Advanced Settings" at the top of the screen to stop the digital signage software from loading.

Device is Offline:

  1. Ethernet Connection:

    1. Check the ethernet connection on the device.

      Look for flashing or illuminated lights above the connection.

    2. Remove and reinsert the power plug.

      After the bouncing white dot, the "Basic Settings" screen should appear.

      Verify it says "Connected" for Ethernet or Wireless LAN.

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